problem z pluginami

Dyskusja w 'Archiwum' rozpoczęta przez użytkownika berih, Lip 17, 2012.

Status tematu:
Brak możliwości dodawania odpowiedzi.
  1. berih
    Offline

    berih Nowicjusz

    Wiadomości:
    0
    Polubienia:
    0
    Punkty:
    3
    Witam
    Na moim serwerze postanowiłem dodać różne klasy postaci np górnik, rzemieślnik itd. Chciałem użyć pluginu simpleitempermissions lecz nie działał. Bukkit w ogóle go nie wykrywał. Potem postanowiłem użyć pluginu heroes lecz i on nie działał. Wiecie może co może być przyczyną? Proszę o szybką odpowiedź. Oba pluginy są  na najnowszą wersję bukkita.
     
  2. dawidz1
    Offline

    dawidz1 Użytkownik Użytkownik

    Wiadomości:
    54
    Polubienia:
    62
    Punkty:
    53
    Do tych pluginów spróbuj wgrać plugin środowiskowy Value...
    Na prace osobiście polecam Jobs (i oczywiście Value do tego) i iConomy ;)
     
  3. berih
    Offline

    berih Nowicjusz

    Wiadomości:
    0
    Polubienia:
    0
    Punkty:
    3
    niestety value nie działa a jobs nie daje możliwości zablokowanie przedmiotów np żeby tylko górnik mógł kopać kamień.
    Próbowałem jeszcze z pluginem modyfiworld ale nie da się mu ustawić permissionsów
    Kod (text):
    1.   gracz:
    2.     prefix: '&6[G]&c'
    3.     default: false
    4.     permissions:
    5.     - modifyworld.blocks.destroy.1
    kiedy jest tak ustawione nie można zniszczyć żadnych klocków nawet stona.
    Kod (text):
    1.  
    2.   gracz:
    3.     prefix: '&6[G]&c'
    4.     default: false
    5.     permissions:
    6.     - modifyworld.*
    7.  
    a w przypadku takiego ustawienia mogę niszczyć wszystko
     
  4. dawidz1
    Offline

    dawidz1 Użytkownik Użytkownik

    Wiadomości:
    54
    Polubienia:
    62
    Punkty:
    53
    Czyli tak, potrzebujesz:
    Pluginy:
    - PermissionsEX
    - iConomy
    - Jobs
    Konfigurujemy je (jeśli nie wiesz jak skonfigurować permissions.yml wygeneruj sobie tu http://goo.gl/20xqh)
    i testujemy ;)
     
  5. berih
    Offline

    berih Nowicjusz

    Wiadomości:
    0
    Polubienia:
    0
    Punkty:
    3
    dawidz1 nie chce być nie miły ale chyba w ogóle nie przeczytałeś mojego posta. Napisałem tam że w jobs nie da się ustawić która praca może używać konkretnych klocków, a permissionsEX posiadam i umiem się nim posługiwać. Chodziło mi o to żeby ktoś mi powiedział dlaczego kiedy mam ustawione w permissions dla jakieś grupy - modifyworld.blocks.destroy.1 to ona i tak nie może niszczyć stona. Czy ja coś źle napisałem czy to błąd pluginu. Pozostałe funkcje modifyworld działają normalnie. edit już udało mi się to zrobić wystarczyło wpisać pełne nazwy a nie id. Mam jeszcze jedno pytanie czy jest plugin który umożliwia po kliknięciu na tabliczkę zmiany rangi w permissions. Bo chciałem żeby każdy mógł sobie wybrać klasę na początku.
     
  6. dawidz1
    Offline

    dawidz1 Użytkownik Użytkownik

    Wiadomości:
    54
    Polubienia:
    62
    Punkty:
    53
    No fakt sry trochę nie zrozumiałem twojego posta.
    OK a więc zamiast:
    Kod (text):
    1. modifyworld.blocks.destroy.1
    spróbuj dać tak:
    Kod (text):
    1. modifyworld.blocks.interact.1
    Trochę szukałem na ten temat i dużo ludzi ma z tym właśnie problem, ale nie wiem czy to prawidłowe rozwiązanie...
     
  7. berih
    Offline

    berih Nowicjusz

    Wiadomości:
    0
    Polubienia:
    0
    Punkty:
    3
    nie chce byc znowu nie mily ale chyba znowu nie doczytales mojego posta do konca (albo pisales w tym samym momencie w ktorym edytowałem) juz sobie poradzilem z tym problemem wystarczylo wpisac pelne nazwy a nie id. Teraz szukam pluginu ktory umozliwia zmiane klasy poprzez klikniecie na tabliczke oraz pluginu ktory umozliwa blokowanie narzedzi dla niektorych grup
     
Status tematu:
Brak możliwości dodawania odpowiedzi.